Hbase与Hadoop版本对应

安装HBase时,要考虑选择正确的Hadoop版本,否则可能出现不兼容的情况。


Hadoop version support matrix
  • "S" = supported/支持

  • "X" = not supported/不支持

  • "NT" = Not tested/没有测试

 

HBase-0.92.x

HBase-0.94.x

HBase-0.96.x

HBase-0.98.x

Hadoop-1.0.0-1.0.2

S

S

X

S

Hadoop-1.0.3+

S

S

S

S

Hadoop-1.1.x

NT

S

S

S

Hadoop-0.23.x

X

S

NT

NT

Hadoop-2.0.x-alpha

X

NT

X

S

Hadoop-2.1.0-beta

X

NT

S

S

Hadoop-2.2.0

X

NT

S

S

Hadoop-2.x

X

NT

S

S


  HBase-1.1.x HBase-1.2.x HBase-1.3.x HBase-2.0.x

Hadoop-2.0.x-alpha

X

X

X

X

Hadoop-2.1.0-beta

X

X

X

X

Hadoop-2.2.0

NT

X

X

X

Hadoop-2.3.x

NT

X

X

X

Hadoop-2.4.x

S

S

S

X

Hadoop-2.5.x

S

S

S

X

Hadoop-2.6.0

X

X

X

X

Hadoop-2.6.1+

NT

S

S

S

Hadoop-2.7.0

X

X

X

X

Hadoop-2.7.1+

NT

S

S

S

Hadoop-2.8.0

X

X

X

X

Hadoop-2.8.1

X

X

X

X

Hadoop-3.0.0-alphax

NT

NT

NT

NT

Hadoop Pre-2.6.1 and JDK 1.8 Kerberos

When using pre-2.6.1 Hadoop versions and JDK 1.8 in a Kerberos environment, HBase server can fail and abort due to Kerberos keytab relogin error. Late version of JDK 1.7 (1.7.0_80) has the problem too. Refer to HADOOP-10786 for additional details. Consider upgrading to Hadoop 2.6.1+ in this case.

Hadoop 2.6.x

Hadoop distributions based on the 2.6.x line must have HADOOP-11710 applied if you plan to run HBase on top of an HDFS Encryption Zone. Failure to do so will result in cluster failure and data loss. This patch is present in Apache Hadoop releases 2.6.1+.

Hadoop 2.7.x

Hadoop version 2.7.0 is not tested or supported as the Hadoop PMC has explicitly labeled that release as not being stable. (reference the announcement of Apache Hadoop 2.7.0.)

Hadoop 2.8.x

Hadoop version 2.8.0 and 2.8.1 are not tested or supported as the Hadoop PMC has explicitly labeled that releases as not being stable. (reference the announcement of Apache Hadoop 2.8.0 and announcement of Apache Hadoop 2.8.1.)

官方文档参考:

http://hbase.apache.org/book.html#configuration




相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页